URL to newly ingested resource is not up-to-date

Project:RUcore Workflow Management System (WMS)
Version:8.1
Component:Ingest
Category:bug report
Priority:normal
Assigned:chadmills
Status:closed
Description

When ingesting a resource the URL in the Ingest Log is something like this:

http://{environment}.libraries.rutgers.edu/dlr/showfed.php?pid=rutgers-lib:xxxx

This is a old URL pattern. The new URL should take this form.

dev: http://rucore-dev.libraries.rutgers.edu/rutgers-lib/{id}/
test: http://rucore-test.libraries.rutgers.edu/rutgers-lib/{id}/
staging: http://rucore-staging.libraries.rutgers.edu/rutgers-lib/{id}/
production: http://rucore.libraries.rutgers.edu/rutgers-lib/{id}/

A full example using the test environment as a base is:

<a href="http://rep-test.libraries.rutgers.edu/dlr/showfed.php?pid=rutgers-lib:203668" title="http://rep-test.libraries.rutgers.edu/dlr/showfed.php?pid=rutgers-lib:203668">http://rep-test.libraries.rutgers.edu/dlr/showfed.php?pid=rutgers-lib:20...</a>

This should be

<a href="http://rucore-test.libraries.rutgers.edu/rutgers-lib/203668/" title="http://rucore-test.libraries.rutgers.edu/rutgers-lib/203668/">http://rucore-test.libraries.rutgers.edu/rutgers-lib/203668/</a>

Comments

#1

Assigned to:yuyang» chadmills
Status:active» test

Test. -YY

#2

Status:test» fixed

This is the URL I see in the pop-up ingest log:
<a href="http://rucore-test.libraries.rutgers.edu/rutgers-lib/203904" title="http://rucore-test.libraries.rutgers.edu/rutgers-lib/203904">http://rucore-test.libraries.rutgers.edu/rutgers-lib/203904</a>

#3

Status:fixed» closed

Back to top