Share your story link on production pointing to dev7-oa site

Project:SOAR (Scholarly Open Access at Rutgers) Website
Version:1.0
Component:Code
Category:bug report
Priority:critical
Assigned:ananthan
Status:Moved to JIRA
Description

1) Search for *44528* in the SOAR (production) search portal. Download the PDF and click on the "Share Your Story" link.
It takes you to: <a href="http://dev7-oa.libraries.rutgers.edu/share-your-story?id=rutgers-lib:44528" title="http://dev7-oa.libraries.rutgers.edu/share-your-story?id=rutgers-lib:44528">http://dev7-oa.libraries.rutgers.edu/share-your-story?id=rutgers-lib:445...</a>
The following error message is displayed:

Notice: Trying to get property of non-object in eval() (line 8 of /usr/local/apache2/htdocs/acquia/oai/modules/php/php.module(80) : eval()'d code).
Notice: Trying to get property of non-object in eval() (line 8 of /usr/local/apache2/htdocs/acquia/oai/modules/php/php.module(80) : eval()'d code).
Notice: Trying to get property of non-object in eval() (line 8 of /usr/local/apache2/htdocs/acquia/oai/modules/php/php.module(80) : eval()'d code).

2) From dev7-oa.libraries.rutgers.edu, search for *203137 and download the PDF. Clicking on the "Share Your Story" link.
You are directed to: <a href="http://dev7-oa.libraries.rutgers.edu/share-your-story?id=rutgers-lib:203137" title="http://dev7-oa.libraries.rutgers.edu/share-your-story?id=rutgers-lib:203137">http://dev7-oa.libraries.rutgers.edu/share-your-story?id=rutgers-lib:203...</a>
No error message is displayed.

Question: Why is the production link pointing to the development site?

Comments

#1

Assigned to:Sam McDonald» yuyang

Sams says this should be assigned to Yang.

#2

Assigned to:yuyang» chadmills

This is on the rutgers-lib display side. A configuration file needs updating.

./rucore/rutgers-lib/lib/configs/story.php

Change line:

$cfgStory['redirect'] = "http://dev7-oa.libraries.rutgers.edu/share-your-story?id=";

to

$cfgStory['redirect'] = "http://soar.libraries.rutgers.edu/share-your-story?id=";

#3

Assigned to:chadmills» ananthan
Status:active» test

Dave changed the configuration on production. I tested and the link now redirects to the correct site.

#4

Assigned to:ananthan» chadmills
Status:test» active

I tested it this morning, and it worked as expected on the production system. The test system link is also redirected to the production system. Does this need to be changed?

#5

Assigned to:chadmills» ananthan

I checked the test system, it is configured to redirect to the test OA site. It might have been the link in the PDF itself. Do you know which PDF on the test OA site redirected to the production OA site when the Share Your Story link was clicked? If so, please attach to this issue.

#6

Status:active» Moved to JIRA

Back to top