Information lost when saving a newly created condition/rule/restriction lacks required metadata

Project:RUcore/NJDH/Partner Portal Search
Version:7.6.1
Component:Portal Creation/Editing/Management - Search Portal Tool
Category:bug report
Priority:normal
Assigned:ananthan
Status:closed
Description

I entered most of the required metadata but the one of the required metadata. When I hit save, "Required fields not supplied." is displayed on the Resource Authorization screen but the record is not saved and lost everything I entered. I had to re-enter the information.

Comments

#1

Assigned to:chadmills» ananthan
Status:active» test

Please test. The creation of any new condition, rules and restrictions should refer you back to the create form if not all of the requirements have been meet. Any preliminary information that was provided should be filled in the form as well.

Same goes for edits. If you edit a condition, rule, or restriction and mistakenly do not provide required information you will be sent back to the edit form with any changes that were submitted still in place; but not saved. At this point you will be able to fill in the required information that was missing and complete the edit.

#2

Status:test» fixed

"Required fields not supplied" message appears on the Resource authorization screen and I am able to supply missing metadata without losing any information. Tested creating a new restriction, rule, and condition. All worked as expected.

#3

Status:fixed» closed

Back to top