Inconsistent messages when displaying statistics when there are no usage statistics available

Project:RUcore Statistics
Version:7.6
Component:Code
Category:feature request
Priority:normal
Assigned:ananthan
Status:closed
Description

From My account, clicking on My collection statistics displays:

You have not submitted any works, or your submitted works are in progress and there are no usage statistics available. If you believe this is an error, please contact the RUcore staff.

From FD form, clicking on Statistics button displays:
The statistics page with a message "0 downloads from 2014-01-01 to 2014-10-29".

It would be nice if these two display the same message when there are no usage statistics available.

Comments

#1

Assigned to:rmarker» jgeng

Within the Faculty Deposit module, change the label in the "statistics" button to "My Collection Statistics". Change the label of the "collection" button to "My Submitted Works".

When the user clicks on the "My Collection Statistics" button but nothing has been ingested, please display this message:

You have not submitted any works, or your submitted works are in progress and there are no usage statistics available. If you believe this is an error, please contact the RUcore staff using the Contact Us button on this page.

Similarly, when the user clicks on the "My Submitted Works" but nothing has been submitted, please display this message:

You have not submitted any works. If you believe this is an error, please contact the RUcore staff using the Contact Us button on this page.

#2

Assigned to:jgeng» rmarker
Status:active» test

ready for 7.6 test.

#3

Assigned to:rmarker» jgeng
Status:test» active

If the user has no works that have been ingested and clicks on "My Collection Statistics", the page shows the header for the statistics display but the rest of the page is blank:

Select Date from [2015-01-01] to [2015-05-07] Get Stats!
Summary Detail 0 downloads from 2015-01-01 to 2015-05-07

There should be a message -- either above this display or instead of it -- that explains why it is blank:
"You have not submitted any works, or your submitted works are in progress and there are no usage statistics available. If you believe this is an error, please contact the RUcore staff using the Contact Us button on this page."

The correct message displays under "My Submitted Works" for someone who has never deposited any works.

#4

Assigned to:jgeng» rmarker

Just want to know if there is no object at all or just no downloads from 2015-01-01 to 2015-05-07.

Thanks,
Jie

#5

Assigned to:rmarker» jgeng

This was tested with a user that had not submitted any works at all. He logged into the system, but never went through the "Deposit Your Work" process. So we want this message under "My Collection Statistics" for these two scenarios:

User has never deposited any works
User has deposited works but they have not been ingested into RUcore

"You have not submitted any works, or your submitted works are in progress and there are no usage statistics available. If you believe this is an error, please contact the RUcore staff using the Contact Us button on this page."

#6

Assigned to:jgeng» rmarker
Status:active» test

Fixed, please test.

#7

Assigned to:rmarker» ananthan

Please ask Fengzhi to test this.

#8

Status:test» fixed

Fengzhi tested it. Clicking on "Collection Statistics"now displays: "You have not submitted any works, or your submitted works are in progress and there are no usage statistics available. If you believe this is an error, please contact the RUcore staff using the Contact Us button on this page."

#9

Status:fixed» closed

Back to top