Error when viewing record

Project:RUcore dlr/EDIT
Version:7.2.1
Component:Code
Category:bug report
Priority:normal
Assigned:triggs
Status:closed
Description

When viewing the following record an error is thrown and the display doesn't show any resource information.

Request: <a href="http://rep-test.libraries.rutgers.edu/dlr/EDIT/showobject.php?pid=rutgers-lib%3A34974" title="http://rep-test.libraries.rutgers.edu/dlr/EDIT/showobject.php?pid=rutgers-lib%3A34974">http://rep-test.libraries.rutgers.edu/dlr/EDIT/showobject.php?pid=rutger...</a>

Error: faultCode0faultStringWarning:file_get_contents(<a href="http://127.0.0.1:8080/fedora/objects/rutgers-lib:34974/datastreams?format=xml" title="http://127.0.0.1:8080/fedora/objects/rutgers-lib:34974/datastreams?format=xml">http://127.0.0.1:8080/fedora/objects/rutgers-lib:34974/datastreams?forma...</a>): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /mellon/htdocs/dlr/EDIT/showobject.inc on line 20faultCode0faultStringFatal error:Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /mellon/htdocs/dlr/EDIT/showobject.inc:21 Stack trace: #0 /mellon/htdocs/dlr/EDIT/showobject.inc(21): SimpleXMLElement->__construct('') #1 /mellon/htdocs/dlr/EDIT/showobject.php(118): include('/mellon/htdocs/...') #2 {main} thrown in /mellon/htdocs/dlr/EDIT/showobject.inc on line 21

Comments

#1

Status:active» test

It should now handle the not found error the way it did with the SOAP interface.

#2

Version:7-x» 7.2.1
Status:test» fixed

#3

Status:fixed» closed

Closing.

Back to top