PHP Warning when accessing a datastream

Project:RUcore/NJDH/Partner Portal Search
Version:7.2.2
Component:User Interface - Service Agent
Category:bug report
Priority:normal
Assigned:chadmills
Status:closed
Description

[15-Aug-2013 10:41:34 America/New_York] PHP Warning: fopen(<a href="http://rucore.libraries.rutgers.edu/api/get/rutgers-lib:36203/PDF/1" title="http://rucore.libraries.rutgers.edu/api/get/rutgers-lib:36203/PDF/1">http://rucore.libraries.rutgers.edu/api/get/rutgers-lib:36203/PDF/1</a>): failed to open stream: HTTP request failed! in /home/httpd/html/rucore/rutgers-lib/lib/renderers/file.php on line 54

Comments

#1

Status:active» test

Added suppression and will investigate why the request wasn't fulfilled. In the meantime keep in mind the if the URL responds with a 1xx, 4xx, or 5xx status code, you will get a "failed to open stream: HTTP request failed!" This can happen if Fedora has an issue with accommodating the request. To test just watch the php_error log.

#2

Assigned to:chadmills» dhoover

#3

Status:test» active

This came from a log entry on production and not from any action
I took online, so I don't know how to test it on rep-devel. Also the rutgers-lib
number stated in this report is not on rep-devel. I also do not see any
error messages on rep-devel for file.php and renderer so it looks like
it is not occuring and may have never occured on rep-devel.

I will suggest keeping it active and looking at the logs on rep-staging, then
rep-prod to see if the message has stopped occuring.

#4

Agreed. I will deliver the expected fix for 7.2.2. Thanks.

#5

Assigned to:dhoover» chadmills

Has this been addressed in R7.2.1?

#6

Version:7.2.1» 7.2.2
Status:active» fixed

I think it was addressed in 7.2.2. I just checked the production error logs and the last entry I found was dated September 16, 2013. 7.2.2 came out on October 17th, 2013. No entries in the error log for this since then. I will mark it as fixed.

#7

Status:fixed» closed

Back to top