Stats pie chart not displaying sometimes...

Project:RUcore/NJDH/Partner Portal Search
Version:7.2.1
Component:User Interface - Service Agent
Category:bug report
Priority:normal
Assigned:rjantz
Status:closed
Description

Some cases where the statistics pie chart isn't working

<a href="http://rucore.libraries.rutgers.edu/rutgers-lib/23921/#statistics" title="http://rucore.libraries.rutgers.edu/rutgers-lib/23921/#statistics">http://rucore.libraries.rutgers.edu/rutgers-lib/23921/#statistics</a>

Comments

#1

Version:7-x» 7.2.1

#2

Status:active» test

This happens when a resource has a total download from more than 10 countries. To test view a record that has been downloaded many times from many countries and confirm the pie chart views are functioning.

Examples:

<a href="http://rucore-test.libraries.rutgers.edu/rutgers-lib/23426/#statistics" title="http://rucore-test.libraries.rutgers.edu/rutgers-lib/23426/#statistics">http://rucore-test.libraries.rutgers.edu/rutgers-lib/23426/#statistics</a>

#3

Assigned to:chadmills» rjantz

#4

Status:test» fixed

The pie chart appears to be displaying properly for those instances where there are downloads from 10 or more countries. I did find one case where an "a" was displayed as a country - see <a href="http://rucore.libraries.rutgers.edu/rutgers-lib/39147/#statistics" title="http://rucore.libraries.rutgers.edu/rutgers-lib/39147/#statistics">http://rucore.libraries.rutgers.edu/rutgers-lib/39147/#statistics</a>

We should close this bug. The "a" may be an anomaly.

#5

Ron,

Thanks for pointing that out. It looks to be a separate issue with the Stats API and I will submit a new entry for that.

#6

Status:fixed» closed

Closing.

Back to top