Validate object - reporting of content model

Project:RUcore dlr/EDIT
Version:8.x
Component:Code
Category:bug report
Priority:minor
Assigned:triggs
Status:Moved to JIRA
Description

The function "validate object" reports “no content model found” for rutgers-lib:201345 although the content model in the technical metadata is “document”.

Ron Jantz

Comments

#1

Version:7.1» 7-x

This will need to worked on in a future release, as it is caused by fundamental changes in the architectures of the objects.

#2

Version:7-x» 7.4

This is be part of the 7.4 enhancement of Validate object.

#3

Version:7.4» 7.5

This seems to have been a casualty of other priorities in 7.4, and will have to be pushed out to 7.5 at least. I don't have final content model specs that I can work with.

#4

Version:7.5» 7.6

Once again there was no time to do this in the brief period between 7.4/7.4.1, and 7.5.

#5

Version:7.6» 7-x

I would very much like to work on this (including reintroduction of the commented-out Fedora-based content-model validation method), but as I noted two years ago to the day, it really needs a complete updating and reworking of the function, and it never seems to get a high enough priority. This release was taken up with the conversion to SSO authentication and there was no time for a new validate function.

#6

Version:7-x» 8.x

Please update status when time permits.

#7

The validate object script needs to be completely rewritten in consultation with Ron, but we did not find time to work on it for this release. It would have to be a pretty big project.

#8

Status:active» Moved to JIRA

Back to top