Clarify that Select Files is a download option

Project:RUcore/NJDH/Partner Portal Search
Component:User Interface - Service Agent
Category:feature request

The Download Options pop-up has two options presented side-by-side: Yes, Download Resource and No, Cancel Download. The option to "Select Files>>" to download is in the bottom corner in a smaller button. I view this as an "in-between" option, literally, and that is my suggestion: place the "Select Files To Download" between the "Yes" and "No" buttons.



Assigned to:aletia.morgan» chadmills

Ryan and I looked at 2/28 - would like to make changes, esp with the term "Resource".

1) would like to change the word "Resource" to "Dataset", to be consistent .

2) I do like the idea of moving the "select files" to the right - where cancel is today - and put cancel where the "select files" is today. The principle is to put the most-likely-used buttons on the upper level of the drop-down box.

Chad - if we come up with something today, are you in a position to edit these labels for 7.0, or should we pick up after Monday?


Cannot make these changes so late in the R7.0 release. You should still finalize your decision and update this issue ASAP so that it makes it in the next release.


Version:7-x» 7.7


Assigned to:chadmills» aletia.morgan
Status:active» test

Since I cannot reliably determine if it is a dataset, project, etc. I have changed the wording from "resource" to "package." Please review this and any other change in this release.

Before: Are you sure you want to download this entire resource?

Proposed: Are you sure you want to download this entire package?


Assigned to:aletia.morgan» chadmills
Status:test» active

Chad - just reviewed. I do agree that using the word "Package" would be preferred in the 7.7 download process - especially since it's consistent with the earlier prompt on the screen:

"The size of this download is approximately 9.61 kb
Are you sure you want to download this entire package?"

But then the button says "Download Resource"

I don't know if there's time, but using the word "Package" in both places on that screen makes a lot of sense, and would be more consistent for the user.

Let me know what makes sense, now or later.



Version:7.7» 8.1
Assigned to:chadmills» aletia.morgan
Status:active» test

Updated language in button to "Download Package". Review during 8.1 testing session.


Status:test» fixed

Updated language to "Download Package" Makes sense - we're done with this one.


Status:fixed» closed

Back to top