Logging into shibboleth issue

Project:RUcore API's
Version:7.0
Component:Get API
Category:bug report
Priority:normal
Assigned:dhoover
Status:closed
Description

Reports that when logging into shibboleth and getting redirected back to the result page yields inaccurate results. Once the user has returned to the result page the links are not avaiable with a access denied message. Upon refreshing the screen in the web browser the links appear. It appears that the access check that is taking place is not accurate the first time when returning from logging into shibboleth. After the initial refresh the results are accurate.

Comments

#1

Project:RUcore/NJDH/Partner Portal Search» RUcore API's
Version:7.0» 7.0
Component:Searching - Service Agent» Get API
Status:active» test

Changed the configuration parameter $cfg_api_get['fedora_connection_timeout'] from 2 to 5 on the development system. Issue looks resolved.

Can test on staging and production by changing this value in the Get API configuration file, /rucore/api/get/lib/configuration.php

This setting will tell the Get API to wait longer for the Fedora checking to see if the user has access. Since the default response is no access and Fedora hasn't been responding with a confirmation in the 2 seconds allotted, a denial is sent back.

Hitting refresh works because then the resource is in the Fedora cache and response improves.

I am also moving this to the RUcore API's project since the search portals are performing as expected and this is a setting in the Get API.

#2

Assigned to:chadmills» dhoover

#3

Status:test» closed

This is so old I am closing it.

Back to top