apostrophe's not working

Project:RUcore/NJDH/Partner Portal Search
Version:6.1
Component:Searching - Service Agent
Category:bug report
Priority:critical
Assigned:chadmills
Status:closed
Description

Apostrophe's are turning into the following character sets:

#039;

For example, see Rutgers University Collection -- De Fino test collection -- Jane Doe#039;s series

Comments

#1

Project:RUcore/NJDH/Partner Portal Search» RUcore Workflow Management System (WMS)
Version:5.2» 5.2
Component:Searching - Service Agent» Metadata

It looks like apostrophes, and maybe other character's, are being store as their corresponding entity in Fedora. See example:

rutgers-lib:25886

<mods:title>Jane Doe's second object.</mods:title>

#2

Component:Metadata» General

Also the colelction name when stored in the collections table doesn't have the propoer apostrophe. It is being stored in the dlrcolelction table as:

John Doe's series.

Maybe there is some filter being run across everything in WMS that is causing the issue.

#3

Assigned to:yuyang» triggs

Jeffery,

The title has the apostrophe in the FOXML in WMS. Also the display in WMS and the metadata entry form in WMS displays this correctly. I wonder if the apostrophe is not being stored correctly in Fedora.

#4

Project:RUcore Workflow Management System (WMS)» RUcore dlr/EDIT
Version:5.2» 5.2
Component:General» Code

#5

I'll have to look at this, but I don't think Fedora would convert an apostrophe to an entity. I'd be interested to see if the underlying code shows ' suggesting that the entity got "escaped" as used to happen. Are you sure it is not & #039; (ignore the space between # and ;) in WMS and that you are viewing it interpreted as an apostrophe?

#6

In the Fedora object it has an & apos; entity:
<dc:title>Jane Doe's second object.</dc:title>
<dc:subject>Spice.</dc:subject>
I think it would be very difficult for Fedora to parse ordinary ' chars to the entity on the fly. I suspect it was entered that way.

#7

Priority:normal» critical

#8

Version:5.2» 5.3
Assigned to:triggs» chadmills

I am assigning this to Chad, but Jeffery and Yang need to be involved also.

#9

Version:5.3» 6-x

#10

Project:RUcore dlr/EDIT» RUcore/NJDH/Partner Portal Search
Version:6-x» 6.1
Component:Code» Searching - Service Agent

This is corrected for this release in the search interface. To test go to an RUcore advanced search and navigate the collection tree to the collection mentioned at the beginning of this bug.

#11

Status:active» test

#12

Status:test» fixed

The apostrophe is appearing now. Thank you!

#13

Status:fixed» closed

See Melissa's comment.

Back to top